Budbee Tracking events synchronisation

Incident Report for Ingrid

Postmortem

On 13 April 2026, Ingrid identified that a subset of merchants using Ingrid Returns had not been receiving tracking status updates for return shipments handled by a specific carrier integration. The issue was limited to the Ingrid Returns product; outbound shipments and other carrier integrations were not affected.

The root cause was a configuration constraint in the carrier integration that limited tracking event delivery to a single processing context. A fix applied earlier in 2026 to restore outbound tracking had inadvertently deactivated the tracking delivery path for the Returns product.

A temporary fix was deployed on 15 April 2026, restoring tracking event delivery for affected merchants. A longer-term architectural fix is in progress.

Timeline (CEST)

  • 13 April 2026, 11:05 — Issue identified; incident declared
  • 15 April 2026, ~09:59 — Fix deployed; Returns tracking events restored
  • 17 April 2026, 17:00 — Incident confirmed resolved
Posted Jun 09, 2026 - 13:56 CEST

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 15:36 CET

Monitoring

A fix has been implemented, we are currently observing the results.
Posted Feb 26, 2026 - 13:34 CET

Investigating

We are currently investigating the issue of budbee tracking events not being synchronised properly for a part of our merchants.
Posted Feb 26, 2026 - 12:28 CET
This incident affected: Tracking.