Returns end users not getting their label

Incident Report for Ingrid

Postmortem

On Sunday, 25 May 2026, Ingrid Returns experienced a disruption affecting return shipment booking and return label generation, beginning at approximately 14:13 CEST. The issue was caused by a limit condition being exceeded within Ingrid's return shipment creation pipeline, causing booking requests to fail.

The issue was identified on the morning of 26 May following merchant reports. A fix was deployed by approximately 10:30 CEST, restoring the ability to book new return shipments. Previously failed bookings were reprocessed and confirmed cleared by approximately 11:17 CEST.

We acknowledge the detection gap and are implementing alerting to catch this type of failure earlier.

Timeline (CEST)

  • 25 May, ~14:13 — Returns booking failures begin
  • 26 May, ~09:30 — Incident identified and declared following merchant reports
  • 26 May, ~10:30 — Fix deployed; new return bookings restored
  • 26 May, ~11:17 — Backlog of failed shipments confirmed fully reprocessed
  • 26 May, ~11:20 — Incident resolved
Posted Jun 09, 2026 - 13:56 CEST

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 13:49 CEST

Identified

Issue identified, mitigated and in progress of re-processing affected Returns.
Posted Apr 15, 2026 - 10:45 CEST

Investigating

We are currently investigating this issue.
Posted Apr 15, 2026 - 10:04 CEST
This incident affected: Returns.