Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 04:00 CET
Scheduled
We will be performing scheduled maintenance on March 20th between 04:00-04:10 CET, during which new shipments cannot be booked through IMP/MAD or the new TA back office.
Generation of tracking numbers will also be impacted during this time for the following carriers: TNT Lotte Budbee Best DB Schenker Posti Dønn Grønn Tamro DHL Airmee Instabox PostNord Ingrid Porterbuddy Citymail Bring
Posted Mar 19, 2025 - 14:17 CET
This scheduled maintenance affected: Tracking, Transport Administration, and Ingrid Merchant Platform.